월별 글 목록: 2016년 1월월

Ubuntu에서 Elixir 사용해 babel 혹은 browserify 할 때 오류 발생시

최근 ES6(혹은 ES2015)를 작업에 조금씩 도입해보고 있습니다.
로컬에서는 별 문제가 없었는데 서버에서 엘릭서를 사용하니

Babel Compilation Failed!: Couldn't find preset "es2015" relative to directory ...

라는 에러가 발생하며 js 트랜스파일이 안됩니다.
혹은

Babel Compilation Failed!: Couldn't find preset "react" relative to directory ...

라는 에러를 만날 수도 있습니다.

에러 내용 그대로, 프리셋을 찾을 수 없다는 에러입니다.
npm에서 프리셋 패키지들만 설치해주면 쉽게 해결됩니다.

npm install babel-preset-es2015
npm install babel-preset-react